Joomla – migration from 1.5 to 2.5

Posted In: blog |

Joomla migration

Unfortunately Joomla upgrade is not automatic in any way. So if you are trying to update you Joomla version from the last LTS (1.5) release to the current LTS (2.5) prepare for trouble. Many framework changes in Joomla! like nested categories and new ACL system make the migration very painfull, for a complicated Joomla installation.

Semi – Automatic migration with JUpgrade

1. First of all upgrade to the latest Joomla 1.5 (1.5.26) (link).
2. Install and enable Mootools Upgrade plugin. (link)
3. Install and run JUpgrade plugin (link).
4. Copy /images folder to new installation, if You used it for media.

If you have trouble with above steps, try turning on debuging in jupgrade and deal with errors that may occour. On some servers, there could be problems with write rights to files, so it can be handy to install joomla 2.5 on your own, outside of jupgrade.

Joomla template migration

There a lot of minor edits in the template files. A very good guide can be found in the joomla magazine. Most common errors that may occur :

There is missing :

If you end up without the content showing, you probably want to fix, a line containing something like:

Other important stuff to do during Joomla migration

If you hate TinyMCE, try installing an another editor for Joomla like : CK Editor, which should be less troubles 🙂

Double check file permissions, that can be found System Information >> Directory Permissions

Installing an another language is very simple, all You have to do is just get the appropriate language pack


Post Tags: joomla | migration |


Comments Off on Joomla – migration from 1.5 to 2.5