Sabayon – nvidia-drivers with old radeon

Posted In: blog |

If You have an older nvidia graphics card you may run into problems trying to install/use Sabayon linux.
For example :

If you get an error during Sabayon live CD install, try to boot with nvidia kernel module disabled. Edit the kernel parameters at the boot menu, adding:

The newest binary nvidia drivers may not support you card if it is to old. But that’s not a problem. Check what versions of nvidia drivers are avaible and uninstall the current driver:

Try installing and testing drivers in a decreasing order:

Than mask drivers above that version by adding to /etc/entropy/packages/package.mask:

Set OpenGL to nvidia. In some cases it helped to switch from nvidia to x11 and backwards.

If you get errors like Invalid parameter NVreg_DeviceFileGID … while inserting the nvidia module, just edit its parameters:

For debugging try:

More:
Sabayon Wiki: HOWTO: Get AMD/ATI or Nvidia Video Cards working in Sabayon


Post Tags: linux | nvidia | sabayon |


Comments Off on Sabayon – nvidia-drivers with old radeon